idea工程配置碰到的坑

技术分享  / 只看大图  / 倒序浏览   ©

#楼主# 2020-2-11

跳转到指定楼层

马上注册,分享更多源码,享用更多功能,让你轻松玩转云大陆。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
1、lombok插件,直接在idea的file-settings里面搜索,没有找到。最后在https://plugins.jetbrains.com/plugin/6317-lombok/versions查看对应idea的2019.3下载,选择"install

plugin from disk"进行离线进行安装的lombok插件


171011p99zfq8ka6iaf661.jpg


2、但是执行gradle同步依赖包后,有依赖包还是没有拉取下来。后来根据idea 2019.03版本,找到一篇文章https://blog.csdn.net/zhaokai0130/article/details/103541980

参考设置如下,果然getset报错就解决了。


171012sa66xw33ss3xczc2.jpg


3、但是仍然有Collections这种依赖包,没拉取下来。后来看报错日志,发现是下载的gradle版本是4.4.1与工程不兼容,把gradle新安装了gradle3.5.1版本,并如上图设置。就解决了很多包拉取失败的问题。
171012mk87sz373p226776.jpg


4、最后发现安装的jdk1.8是ubuntu自带的,项目中依赖的jfxrt.jar包没有,导致依赖报红。

171013tztx9q9zqvhqajis.jpg



5、把对应的jfxrt.jar拷贝到对应的jar目录即可。

171014j7gdnkbbcnzbtbd4.jpg



6、在设置中,可能存在内存不够用,以及使用lombok插件,但是没有勾选enable annotation processing选项的问题。



171014thhu73g77uilz1a7.jpg




171015rrahz7rb5pt2euoe.jpg
分享淘帖
回复

使用道具

您的回复是对作者最大的奖励

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关于作者

18860112078

新手猿

  • 主题

    6

  • 帖子

    6

  • 关注者

    0

Archiver|手机版|小黑屋|云大陆 | 赣ICP备18008958号-4|网站地图
Powered by vrarz.com!  © 2019-2020版权所有云大陆